const regex = />\s+</g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('>\\s+<', 'g')
const str = `<div>
<p>Some paragraph here</p>
<div data="some data > < here">
<p>some subparagraph here</p>
</div>
</div>`;
const subst = `><`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);