#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "26[68]+?[687]+?4"
Local $sString = "Samples of valid strings are like 26874" & @CRLF & _
"'266868874', '268787866668887774', '268688788774'. 26666868886688874" & @CRLF & _
"Invalid strings are like '263874', '268734', '2688668778868714', etc... 2324235235980980"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")