const regex = /26[68]+?[687]+?4/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('26[68]+?[687]+?4', 'g')
const str = `Samples of valid strings are like 26874
'266868874', '268787866668887774', '268688788774'. 26666868886688874
Invalid strings are like '263874', '268734', '2688668778868714', etc... 2324235235980980`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}