import re
regex = re.compile(r"26[68]+?[687]+?4")
test_str = ("Samples of valid strings are like 26874\n"
"'266868874', '268787866668887774', '268688788774'. 26666868886688874\n"
"Invalid strings are like '263874', '268734', '2688668778868714', etc... 2324235235980980")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")