import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "26[68]+?[687]+?4";
final String string = "Samples of valid strings are like 26874\n"
+ "'266868874', '268787866668887774', '268688788774'. 26666868886688874\n"
+ "Invalid strings are like '263874', '268734', '2688668778868714', etc... 2324235235980980";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}