$re = '/26[68]+?[687]+?4/';
$str = 'Samples of valid strings are like 26874
\'266868874\', \'268787866668887774\', \'268688788774\'. 26666868886688874
Invalid strings are like \'263874\', \'268734\', \'2688668778868714\', etc... 2324235235980980';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);