// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"26[68]+?[687]+?4").unwrap();
let string = "Samples of valid strings are like 26874
'266868874', '268787866668887774', '268688788774'. 26666868886688874
Invalid strings are like '263874', '268734', '2688668778868714', etc... 2324235235980980";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}