#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\((\d+).?\)"
Local $sString = "Здравствуйте. Подскажите, как найти цифры, внутри скобок?" & @CRLF & _
"4(500р)" & @CRLF & _
"" & @CRLF & _
"sgfgdfg(33456)" & @CRLF & _
"" & @CRLF & _
"dsfgfd(1)gfgf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")