// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\((\d+).?\)").unwrap();
let string = "Здравствуйте. Подскажите, как найти цифры, внутри скобок?
4(500р)
sgfgdfg(33456)
dsfgfd(1)gfgf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}