using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((\d+).?\)";
string input = @"Здравствуйте. Подскажите, как найти цифры, внутри скобок?
4(500р)
sgfgdfg(33456)
dsfgfd(1)gfgf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}