import re
regex = re.compile(r"\((\d+).?\)")
test_str = ("Здравствуйте. Подскажите, как найти цифры, внутри скобок?\n"
"4(500р)\n\n"
"sgfgdfg(33456)\n\n"
"dsfgfd(1)gfgf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")