re = /\((\d+).?\)/
str = 'Здравствуйте. Подскажите, как найти цифры, внутри скобок?
4(500р)
sgfgdfg(33456)
dsfgfd(1)gfgf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end