package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((\d+).?\)`)
var str = `Здравствуйте. Подскажите, как найти цифры, внутри скобок?
4(500р)
sgfgdfg(33456)
dsfgfd(1)gfgf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}