using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:ticket(?:\s+number)?|number)\.?\s?:?\s*(\S+)";
string input = @"ticket number A2-177653
ticket : A2-177653
number 454544 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}