// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)(?:ticket(?:\s+number)?|number)\.?\s?:?\s*(\S+)").unwrap();
let string = "ticket number A2-177653
ticket : A2-177653
number 454544 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}