package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(?:ticket(?:\s+number)?|number)\.?\s?:?\s*(\S+)`)
var str = `ticket number A2-177653
ticket : A2-177653
number 454544 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}