$re = '/(?i)(?:ticket(?:\s+number)?|number)\.?\s?:?\s*(\S+)/m';
$str = 'ticket number A2-177653
ticket : A2-177653
number 454544 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);