# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?(?<=x)\s*?(\d*\.?\d+).*/\1/gm;t' <<< "2 x 3 kg PPG etc
bob 2 x 3 kg PPG etc
1.5x1.5kgPPGetcFred
BobFred1.5x1.5kgPPGetcFred
1.5 x 2.3 kg PPG Fred Bob
bob Fred 1.5 x 2.3 kg PPG Fred Bob
"