const regex = /.*?(?<=x)\s*?(\d*\.?\d+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(?<=x)\\s*?(\\d*\\.?\\d+).*', 'gm')
const str = `2 x 3 kg PPG etc
bob 2 x 3 kg PPG etc
1.5x1.5kgPPGetcFred
BobFred1.5x1.5kgPPGetcFred
1.5 x 2.3 kg PPG Fred Bob
bob Fred 1.5 x 2.3 kg PPG Fred Bob
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);