#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*?(?<=x)\s*?(\d*\.?\d+).*"
Local $sString = "2 x 3 kg PPG etc" & @CRLF & _
                "bob 2 x 3 kg PPG etc" & @CRLF & _
                "1.5x1.5kgPPGetcFred" & @CRLF & _
                "BobFred1.5x1.5kgPPGetcFred" & @CRLF & _
                "1.5 x 2.3 kg PPG Fred Bob" & @CRLF & _
                "bob Fred 1.5 x 2.3 kg PPG Fred Bob" & @CRLF & _
                ""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)