re = /.*?(?<=x)\s*?(\d*\.?\d+).*/m
str = '2 x 3 kg PPG etc
bob 2 x 3 kg PPG etc
1.5x1.5kgPPGetcFred
BobFred1.5x1.5kgPPGetcFred
1.5 x 2.3 kg PPG Fred Bob
bob Fred 1.5 x 2.3 kg PPG Fred Bob
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result