import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?(?<=x)\\s*?(\\d*\\.?\\d+).*";
final String string = "2 x 3 kg PPG etc\n"
+ "bob 2 x 3 kg PPG etc\n"
+ "1.5x1.5kgPPGetcFred\n"
+ "BobFred1.5x1.5kgPPGetcFred\n"
+ "1.5 x 2.3 kg PPG Fred Bob\n"
+ "bob Fred 1.5 x 2.3 kg PPG Fred Bob\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}