# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^•.*\K\r?\n\r?\n(?=(?!•).*\r?\n\r?\n•)/ /gm;t' <<< "• This is a bulleted line.
This should remain on a separate line
because this line is not bulleted
• This is a bulleted line.
This line SHOULD be absorbed into the one above
• because this line which follows it is bulleted too."