#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^•.*\K\r?\n\r?\n(?=(?!•).*\r?\n\r?\n•)"
Local $sString = "• This is a bulleted line." & @CRLF & _
"" & @CRLF & _
"This should remain on a separate line" & @CRLF & _
"" & @CRLF & _
"because this line is not bulleted" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"• This is a bulleted line." & @CRLF & _
"" & @CRLF & _
"This line SHOULD be absorbed into the one above" & @CRLF & _
"" & @CRLF & _
"• because this line which follows it is bulleted too."
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)