# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^•.*\K\r?\n\r?\n(?=(?!•).*\r?\n\r?\n•)"
test_str = ("• This is a bulleted line.\n\n"
"This should remain on a separate line\n\n"
"because this line is not bulleted\n\n\n"
"• This is a bulleted line.\n\n"
"This line SHOULD be absorbed into the one above\n\n"
"• because this line which follows it is bulleted too.")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.