$re = '/^•.*\K\r?\n\r?\n(?=(?!•).*\r?\n\r?\n•)/m';
$str = '• This is a bulleted line.
This should remain on a separate line
because this line is not bulleted
• This is a bulleted line.
This line SHOULD be absorbed into the one above
• because this line which follows it is bulleted too.';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;