use strict;
my $str = '• This is a bulleted line.
This should remain on a separate line
because this line is not bulleted
• This is a bulleted line.
This line SHOULD be absorbed into the one above
• because this line which follows it is bulleted too.';
my $regex = qr/^•.*\K\r?\n\r?\n(?=(?!•).*\r?\n\r?\n•)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";