using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^•.*\K\r?\n\r?\n(?=(?!•).*\r?\n\r?\n•)";
string substitution = @" ";
string input = @"• This is a bulleted line.
This should remain on a separate line
because this line is not bulleted
• This is a bulleted line.
This line SHOULD be absorbed into the one above
• because this line which follows it is bulleted too.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}