#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([135]\R).+\R"
Local $sString = "#STNEW:_TEST-1" & @CRLF & _
"blablablabla" & @CRLF & _
"#STNEW:_TEST-2" & @CRLF & _
"blablablabla" & @CRLF & _
"#STNEW:_TEST-3" & @CRLF & _
"blablablabla" & @CRLF & _
"#STNEW:_TEST-4" & @CRLF & _
"blablablabla" & @CRLF & _
"#STNEW:_TEST-5" & @CRLF & _
"blablabla" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")