using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([135]\R).+\R";
string input = @"#STNEW:_TEST-1
blablablabla
#STNEW:_TEST-2
blablablabla
#STNEW:_TEST-3
blablablabla
#STNEW:_TEST-4
blablablabla
#STNEW:_TEST-5
blablabla
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}