use strict;
my $str = '#STNEW:_TEST-1
blablablabla
#STNEW:_TEST-2
blablablabla
#STNEW:_TEST-3
blablablabla
#STNEW:_TEST-4
blablablabla
#STNEW:_TEST-5
blablabla
';
my $regex = qr/([135]\R).+\R/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}