// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([135]\R).+\R").unwrap();
let string = "#STNEW:_TEST-1
blablablabla
#STNEW:_TEST-2
blablablabla
#STNEW:_TEST-3
blablablabla
#STNEW:_TEST-4
blablablabla
#STNEW:_TEST-5
blablabla
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}