re = /([135]\R).+\R/m
str = '#STNEW:_TEST-1
blablablabla
#STNEW:_TEST-2
blablablabla
#STNEW:_TEST-3
blablablabla
#STNEW:_TEST-4
blablablabla
#STNEW:_TEST-5
blablabla
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end