#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<\/td>[^<]*<td[^>]*>)\s*\S+\s\S+,\s*([^<]* <\/td> [^<]* <\/tr>)"
Local $sString = "<table border="1" cellpadding="7" cellspacing="0">" & @CRLF & _
" <tr>" & @CRLF & _
" <td colspan="2" bgcolor="#D3EDF6" align="center">1</td>" & @CRLF & _
" <td width="98%" valign="top">2</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td valign="top" align="center">3</td>" & @CRLF & _
" <td width="98%" valign="top">-4314 </td>" & @CRLF & _
" <td class="resclass"> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td colspan="2" bgcolor="#D3EDF6" align="center">6</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td valign="top" align="center">7</td>" & @CRLF & _
" <td width="98%" valign="top">8</td>" & @CRLF & _
" <td class="resclass"> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")