import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\/td>[^<]*<td[^>]*>)\\s*\\S+\\s\\S+,\\s*([^<]* <\\/td> [^<]* <\\/tr>)";
final String string = "<table border=\"1\" cellpadding=\"7\" cellspacing=\"0\">\n"
+ " <tr>\n"
+ " <td colspan=\"2\" bgcolor=\"#D3EDF6\" align=\"center\">1</td>\n"
+ " <td width=\"98%\" valign=\"top\">2</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td valign=\"top\" align=\"center\">3</td>\n"
+ " <td width=\"98%\" valign=\"top\">-4314 </td>\n"
+ " <td class=\"resclass\"> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td colspan=\"2\" bgcolor=\"#D3EDF6\" align=\"center\">6</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td valign=\"top\" align=\"center\">7</td>\n"
+ " <td width=\"98%\" valign=\"top\">8</td>\n"
+ " <td class=\"resclass\"> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>\n"
+ " </tr>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}