using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\/td>[^<]*<td[^>]*>)\s*\S+\s\S+,\s*([^<]* <\/td> [^<]* <\/tr>)";
string input = @"<table border=""1"" cellpadding=""7"" cellspacing=""0"">
<tr>
<td colspan=""2"" bgcolor=""#D3EDF6"" align=""center"">1</td>
<td width=""98%"" valign=""top"">2</td>
</tr>
<tr>
<td valign=""top"" align=""center"">3</td>
<td width=""98%"" valign=""top"">-4314 </td>
<td class=""resclass""> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>
</tr>
<tr>
<td colspan=""2"" bgcolor=""#D3EDF6"" align=""center"">6</td>
</tr>
<tr>
<td valign=""top"" align=""center"">7</td>
<td width=""98%"" valign=""top"">8</td>
<td class=""resclass""> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>
</tr>
</table>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}