const regex = /(<\/td>[^<]*<td[^>]*>)\s*\S+\s\S+,\s*([^<]* <\/td> [^<]* <\/tr>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\\/td>[^<]*<td[^>]*>)\\s*\\S+\\s\\S+,\\s*([^<]* <\\\/td> [^<]* <\\\/tr>)', 'gm')
const str = `<table border="1" cellpadding="7" cellspacing="0">
<tr>
<td colspan="2" bgcolor="#D3EDF6" align="center">1</td>
<td width="98%" valign="top">2</td>
</tr>
<tr>
<td valign="top" align="center">3</td>
<td width="98%" valign="top">-4314 </td>
<td class="resclass"> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>
</tr>
<tr>
<td colspan="2" bgcolor="#D3EDF6" align="center">6</td>
</tr>
<tr>
<td valign="top" align="center">7</td>
<td width="98%" valign="top">8</td>
<td class="resclass"> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>
</tr>
</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}