#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=PHP Fatal error)(.*)(?=router)"
Local $sString = "PHP Fatal error" & @CRLF & _
"adsfasdf" & @CRLF & _
"asdf" & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
"sdf" & @CRLF & _
"#1" & @CRLF & _
"@" & @CRLF & _
"router"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")