re = /(?<=PHP Fatal error)(.*)(?=router)/
str = 'PHP Fatal error
adsfasdf
asdf
a
sdf
#1
@
router'
# Print the match result
str.match(re) do |match|
puts match.to_s
end