import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=PHP Fatal error)(.*)(?=router)";
final String string = "PHP Fatal error\n"
+ "adsfasdf\n"
+ "asdf\n\n"
+ "a\n"
+ "sdf\n"
+ "#1\n"
+ "@\n"
+ "router";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}