const regex = /(?<=PHP Fatal error)(.*)(?=router)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=PHP Fatal error)(.*)(?=router)', 's')
const str = `PHP Fatal error
adsfasdf
asdf
a
sdf
#1
@
router`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}