using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=PHP Fatal error)(.*)(?=router)";
string input = @"PHP Fatal error
adsfasdf
asdf
a
sdf
#1
@
router";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}