$re = '/(?<=PHP Fatal error)(.*)(?=router)/s';
$str = 'PHP Fatal error
adsfasdf
asdf
a
sdf
#1
@
router';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);