#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<a.*href=(("|')(.*pdf)("|')))"
Local $sString = "<a href="https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf">Un Lienn</a>"
Local $sSubst = "$1 download"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)