using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a.*href=((""|')(.*pdf)(""|')))";
string substitution = @"$1 download";
string input = @"<a href=""https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf"">Un Lienn</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}