import Foundation
let pattern = #"(<a.*href=(("|')(.*pdf)("|')))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<a href="https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf">Un Lienn</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 download"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)