const regex = /(<a.*href=(("|')(.*pdf)("|')))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a.*href=(("|\')(.*pdf)("|\')))', 'gm')
const str = `<a href="https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf">Un Lienn</a>`;
const subst = `$1 download`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);