package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<a.*href=(("|')(.*pdf)("|')))`)
var str = `<a href="https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf">Un Lienn</a>`
var substitution = "$1 download"
fmt.Println(re.ReplaceAllString(str, substitution))
}