#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\r?\n(?!:)"
Local $sString = ":86:Mitsubishi Co Ltd" & @CRLF & _
"1-19, Higashi 88" & @CRLF & _
"MHCBJPJTXXX" & @CRLF & _
"SCN123" & @CRLF & _
":61:2202280228C211619,64NMSCSWEEP A/C 555603" & @CRLF & _
":86:Mitsubishi Co Ltd" & @CRLF & _
"MHCBJPJTXXX" & @CRLF & _
"MHCBJPJTXXX" & @CRLF & _
"MHCBJPJTXXX"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)