import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\r?\\n(?!:)";
final String string = ":86:Mitsubishi Co Ltd\n"
+ "1-19, Higashi 88\n"
+ "MHCBJPJTXXX\n"
+ "SCN123\n"
+ ":61:2202280228C211619,64NMSCSWEEP A/C 555603\n"
+ ":86:Mitsubishi Co Ltd\n"
+ "MHCBJPJTXXX\n"
+ "MHCBJPJTXXX\n"
+ "MHCBJPJTXXX";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}